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AquaLink® RS
PC-Computer 
Interface/Docking 
Station

Installation and 
Operation Manual

 WARNING
FOR YOUR SAFETY - This product must be installed and serviced by a pro fes sion al pool/spa 
service technician. The procedures in this manual must be followed ex act ly.   Failure to follow 
warning notices and instructions may result in property damage, serious injury, or death.

This manual contains important information about the installation, operation and safe use of 
this product. This information should be given to the owner/operator of this equipment.
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FOR YOUR SAFETY: This product must be installed and serviced by authorized personnel qual i fied 
in pool/spa installation and maintenance. Improper installation and/or operation will void the warranty. 

  WARNING
Risk of Electrical Shock or Electrocution. This product must be installed by a licensed or certified 
electrician in accordance with the National Electrical Code and all applicable local codes and 
ordinances. Improper installation may create an electrical hazard which could result in death or 
serious injury to pool users, installer, or others due to electrical shock, and may also cause damage 
to property. 

Section 1. Safety Information

IMPORTANT SAFETY INSTRUCTIONS
READ AND FOLLOW ALL INSTRUCTIONS

SAVE THESE INSTRUCTIONS

 ATTENTION INSTALLER: This manual contains important information about the 
installation, operation and safe use of this product. This information should be given to 
the owner/operator of this equipment.
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Section 2. System Description

The AquaLink® RS PC-Computer Interface/
Docking Station allows you to use any personal 
computer that has a Windows® operating system 
(see Section 3, System Requirements) to monitor 
and control the operation of your AquaLink RS 
system as well as download and upload programs 
and settings. All func tions of the AquaLink RS 
can be accessed from the computer; for example, 
you can turn on the filter pump, change the heater 
thermostat setting, or run any auxiliary function. 
The interface has the option to display a control 
panel on the computer screen that simulates the 
AquaLink RS All Button or OneTouchTM control 
panel.  

After you use the AquaLink RS PC-Computer 
Interface/Docking Station to program your 
AquaLink RS system with your desired settings, 
you can use the AquaLink PC Dock application to 
save these settings to a file. The settings file can 
then be downloaded to the Power Center PCB of 
other AquaLink RS systems.  

NOTE The saved settings file can only be downloaded 
to the same RS model.  For example, a settings 
file for an AquaLink RS16 combination system 
can only be transferred to other AquaLink RS16 
combination systems, not an AquaLink RS8.

NOTE A Revision G or higher Programmable 
Peripheral Device (PPD) must be in stalled in 
the AquaL ink RS Power Center for operation 
of the AquaLink PC Interface. A Revision L or 
higher PPD must be installed in the AquaLink 
RS Power Center for operation of the AquaLink 
PC Docking System.

Section 3. System Requirements

To use the AquaLink RS PC-Computer Interface, 
you will need the following:

• A 386 or higher IBM-compatible computer 
with a minimum of 4 MB of RAM (8 MB 
recommended)

• A hard disk drive with at least 13 MB of free 
disk space

• An available communications (comm) port on 
the back of your PC, or an available USB port

• Windows 3.1®, Windows for Workgroups®, 
Windows 95®, 98®, 2000, NT4.0, ME, or XP

NOTE With Windows 2000® (and Service Pack 2) you 
must first start your computer. After start up, 
connect the AquaLink PC cable to the proper 
comm port.
Windows XP® may require you to click OK 
on the Search dialog box, interrupting the 
automatic search for comm port. You then can 
select the name of the correct serial port from 
the pull-down box.

3.1 All Buttom PPD Firmware Verifi cation

To verify the firmware revision on an All Button 
Control Panel, press the recessed switch located 
in the hole on the left side of the panel (see Figure 
1). Hold the switch depressed for approximately 5 
seconds. 

Figure 1. AquaLink RS All Button 

Recessed Switch

NOTE You may use a toothpick or other small pointed 
object to press the switch. 

After releasing the switch, the All Button will 
display the Firmware revision. Ensure the revision 
is G or higher.

If a higher revision PPD is necessary, contact Jandy 
Technical Support at 707-776-8200, ext. 260. 
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2. Turn off the power to the computer. 

3. Run a 22 AWG, 4-conductor color coded 
wire from the red 4-pin terminal bar in the 
AquaLink system (either in the RS Control 
Panel as shown in Figure 3 by the solid 
line or in the Power Center as shown by the 
dotted line) to your computer location. 

4. Open the RS 485/232 Interface by carefully 
removing and saving the 2 screws in its 
housing.

5. Connect the 4-conductor wire as shown in 
Figure 3, and reassemble the connector and 
housing.

6. Select a serial (comm) port to use with this 
interface.  

NOTE A typical comm port consists of a 9-pin male 
connection and may be marked A or B.  If the 
comm port is a 25-pin male connection, plug 
the RS 485/232 Interface directly into that port.  
If the port is a 9-pin male connection, plug the 
25 pin to 9 pin adapter cable (provided) into the 
comm port, then plug the RS 485/232 Interface 
into the adapter cable.

4.2 Software Installation

4.2.1 Windows 3.1 or Windows for 
Workgroups Installation

1. Turn on the power to both the AquaLink RS 
system and to your computer.

2. Type WIN at the DOS command prompt to 
start Windows.

3. Make sure no other applications are 
running. Press CTRL+ESC to display the 
Task List. If ap pli ca tions other than the 
Program Manager are running, select each 
one and click End Task.

4. Insert the Install Disk in the computer CD 
drive.

5. Double-click the Program Manager icon.

6. From the Program Manager's File menu, 
choose Run.

7. Type the fi le name D:\aqlinkpc.exe and 
click OK.

8. Follow the on-screen prompts. 

3.2 OneTouch PPD Firmware Verifi cation

To verify the firmware revision on a OneTouch 
control panel, highlight MENU/HELP and press 
SELECT, highlight HELP and press SELECT (see 
Figure 2). Highlight DIAGNOSTICS by using the 
UP/DOWN arrow keys and press SELECT. The 
DIAGNOSTICS screen displays the firmware 
revision level.
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GO BACK

HELP
Choose a topic
with arrow keys
and press select

MENU

HELP
PROGRAM
SET TEMP
SET TIME
DISPLAY LIGHT
LOCKOUTS
PROGRAM GROUP
SYSTEM SETUP

MODEL
TYPE
FIRMWARE
BATTERY
TIME CAL

NEXT

6529
RS-8 Combo

L
LOW
0 2
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AIR
SOLAR

OK
OK
OK

SENSORS

Figure 2. OneTouch Diagnostics Menu

NOTE When the AquaLink RS PC-Computer Interface/
Docking Station is installed, it becomes one of 
the control panels in the system (Control Panel 
#4). If the AquaLink RS system has one or more 
control panels, ensure that none of them is set 
up as Control Panel #4.  Check this by using 
the Diagnostics menu or by verifying that each 
control panel has at least 1 jumper on the 2 
pairs of internal posts marked “W1” and “W2” 
(refer to the AquaLink RS Installation Manual 
for details). 

Section 4. Installation

4.1 Hardware Installation

NOTE Please refer to the wiring diagram in Figure 3 
when performing the following procedure.
A USB-to-Serial Adapter is included if your 
computer does not have a serial port. Please 
load the USB-to-Serial Adapter Installation CD 
if you are planning to use the USB-to-Serial 
Adapter.

1. Turn off the power to the AquaLink RS at 
the Power Center.  
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NOTE The AquaLink RS allows each system to support a maximum of four (4) indoor control panels. The AquaLink 
PC is considered one of the indoor control panels. The control panels may be wired in "series" starting from 
the controller (solid line), or wired individually from the "Power Center" (dotted line), or a combination of the 
two. To accomplish the "in series" wiring scheme, you may "double-up" wires into each pin on the red 4-pin 
terminal bar, but never put more than two (2) wires into each pin. If you need to join more than two (2) of 
the 4-wire cables, order and install Jandy Part #6584 (Multiplex PCB Kit). 

RS®
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Figure 3. Wiring Diagram
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NOTE If you have a OneTouch control panel 
connected to the power center PCB, you can 
verify that the power center is communicating 
with the PC Docking application. On the 
OneTouch, go to the Diagnostics Menu (see 
Figure 5). Select NEXT. The REMOTES screen 
opens and displays ONETOUCH and PC 
DOCK.

Figure 4. PC Docking Application Main Dialog Box

4.2.2 Windows 95, 98, 2000, NT4.0, ME, or XP 
Installation

1. Turn on the power to both the AquaLink RS 
system and to your computer.

2. Open Windows on your computer. 

3. Ensure that no other applications are 
running. If applications other than the 
Program Manager are running, close them. 

4. Insert the Install Disk in the computer CD 
drive.

5. From the Start menu, choose Run.

6. Type D:\aqlinkpc.exe and click OK.

7. Follow the on-screen prompts.  

Section 5. PC Docking Application 
Instructions

To open the PC Docking application go to the 
Start menu, and choose Programs, Aqualink 
PC Docking or click on the AquaLink PC icon.  
For infomation about operating the All Button or 
OneTouch control panel, refer to the AquaLink RS 
System Owner’s Manual.

NOTE Ensure the RS 485/232 Interface is installed. 
See Section 4.1, Hardware Installation.

5.1 Data Transfer from AquaLink RS Power 
Center PCB to File

The following set of instructions allows you to 
transfer the existing AquaLink RS settings from a 
Power Center PCB to your computer using the PC 
Docking application.

1. On your computer, start PC Docking 
application. From the Start menu, select 
Programs > Aqualink RS System 
Simulation> PC Dock. Figure 4 illustrates 
the PC Docking application in an AquaLink 
RS16 combination system with fi rmware 
Revision L.

2. To read the setup data from the Power 
Center, click From RS System (see Figure 
4). The setup data will take approximately 
30 seconds to load. The Transfer Status 
dialog box opens during the data transfer 
(see Figure 6).
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Figure 5. OneTouch Diagnostics Menu
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4. After the data transfer is complete, you can 
save the setup data to a fi le. From the File 
menu, choose Save As. The File Save As 
dialog box opens and allows you to name 
the fi le as well as specify the directory 
(folder) where you want to store the data 
(see Figure 8). 

NOTE The filenames are limited to 8 characters with a 
3 character extension. 

Figure 7. Transfer Complete Status in Main Dialog 
Box 

3. When the data transfer is complete, click 
OK. The PC Docking application opens and 
reports that the data is loaded as shown in 
the dialog box in Figure 7.

Figure 8. Save As Dialog Box

Figure 9. PC Docking Application Main Dialog Box

5.2 Data Transfer from File to Power Center 
PCB

The following set of instructions allows you to 
transfer your AquaLink RS settings from the 
simulator to your computer using the PC Docking 
application.

1. On your computer, start PC Docking 
application. From the Start menu, select 
Programs > Aqualink RS System 
Simulation> PC Dock. Figure 9 illustrates 
the PC Dock application in an AquaLink 
RS16 combination system with fi rmware 
Revision L.

NOTE If you have a OneTouch control panel 
connected to the power center PCB, you can 
verify that the power center is communicating 
with the PC Docking application. On the 
OneTouch, go to the Diagnostics Menu (see 
Figure 5). Select NEXT. The REMOTES screen 
opens and displays ONETOUCH and PC 
DOCK. 

2. Open the setup fi le that you want to send 
to the Power Center PCB. From the File 
menu, choose Open. The File Open dialog 
box opens and allows you to select the 
fi le that contains the setup data you want 
to transfer to the Power Center PCB (see 
Figure 10). 

Figure 10. File Open Dialog Box

5. To close the PC Docking application, 
choose Exit from the File menu, or click the 
Close icon .  

Figure 6. Transfer Status Dialog Box
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3. To transfer the setup data from the selected 
fi le to the Power Center PCB, click To 
RS System. The setup data will take 
approximately 30 seconds to load. The 
Transfer Status dialog box opens during the 
data transfer (see Figure 11).

Figure 11. Data Transfer from Selected File to 
Power Center PCB

4. To close the PC Docking application, 
choose Exit from the File menu, or click the 
Close icon .  

5.3 Create Setup Files with the Simulator

NOTE If the AquaLink PC-Computer Interface is still 
connected to your computer, disconnect it. It will 
not be used for the following procedure.

1. Close the PC Docking application if it is 
still open.

2. From the Start menu, select Programs > 
Aqualink RS System Simulation> Power 
Center. The Power Center simulator 
application opens.

3. From the Start menu, select Programs 
> Aqualink RS System Simulation> 
OneTouch Panel. The OneTouch control 
panel opens and allows you to setup the 
AquaLink RS system. Program your desired 
settings in the OneTouch control panel.

4. From the Start menu, select Programs > 
Aqualink RS System Simulation> PC 
Dock. The PC Docking application opens.

5. To create setup fi les, click From RS 
System.

6. From the File menu, choose Save As. The 
File Save As dialog box opens.

7. Save as many unique setup fi les as needed. 
At a later time, you can use the steps in 
Section 5.2 to download these setup fi les to 
the Power Center PCB.

Section 6. Parts List

Part Number Description

7270 AquaLink RS PC Interface/Docking 
Station Kit
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LIMITED WARRANTY
Thank you for purchasing Jandy® pool and spa products. Jandy Pool Products, Inc. warrants all parts to be free
from manufacturing defects in materials and workmanship for a period of one year from the date of retail 
purchase, with the following exceptions:

• AquaLink® RS units installed with Jandy® Surge Protection Kits will be covered for two years.
• NeverLube® valves are warranted for the life of pool and/or spa on which they were originally installed.
• AquaPureTM Electronic Chlorine Generator Electrolytic Cells carry a 5 year limited warranty on a prorated basis.

This warranty is limited to the first retail purchaser, is not transferable, and does not apply to products that have 
been moved from their original installation sites. The liability of Jandy Pool Products, Inc. shall not exceed the 
repair or replacement of defective parts and does not include any costs for labor to remove and reinstall the 
defective part, transportation to or from the factory, and any other materials required to make the repair. This 
warranty does not cover failures or malfunctions resulting from the following:

1. Failure to properly install, operate or maintain the product(s) in accordance with our published Installation,
Operation and Maintenance Manuals provided with the product(s).

2. The workmanship of any installer of the product(s).
3. Not maintaining a proper chemical balance in your pool and/or spa [pH level between 7.2 and 7.8, Total

Alkalinity (TA) between 80 to 120 ppm, Total Dissolved Solids (TDS) less than 2000 not including salt ppm].
4. Abuse, alteration, accident, fire, flood, lightning, rodents, insects, negligence or acts of God.
5. Scaling, freezing, or other conditions causing inadequate water circulation.
6. Operating the product(s) at water flow rates outside the published minimum and maximum specifications.
7. Use of non-factory authorized parts or accessories in conjunction with the product(s).
8. Chemical contamination of combustion air or improper use of sanitizing chemicals, such as introducing

sanitizing chemicals upstream of the heater and cleaner hose or through the skimmer.
9. Overheating; incorrect wire runs; improper electrical supply; collateral damage caused by failure of O-Rings,

DE grids, or cartridge elements; or damage caused by running the pump with insufficient quantities of water.

LIMITATION OF LIABILITY:
This is the only warranty given by Jandy Pool Products, Inc. No one is authorized to make any other warranties 
on behalf of Jandy Pool Products, Inc. THIS WARRANTY IS IN LIEU OF ALL OTHER WARRANTIES, 
EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO ANY IMPLIED WARRANTIES OF FITNESS 
FOR A PARTICULAR PURPOSE AND MERCHANTABILITY. JANDY POOL PRODUCTS, INC. EXPRESSLY 
DISCLAIMS AND EXCLUDES ANY LIABILITY FOR CONSEQUENTIAL, INCIDENTAL, INDIRECT OR 
PUNITIVE DAMAGES FOR BREACH OF ANY EXPRESSED OR IMPLIED WARRANTY. This warranty gives 
you specific legal rights. You may also have other rights which vary by state or province.

WARRANTY CLAIMS:
For prompt warranty consideration, contact your dealer and provide the following information: proof of purchase, 
model number, serial number and date of installation. The installer will contact the factory for instructions 
regarding the claim and to determine the location of the nearest designated service center. If the dealer is not 
available, you can locate a service center in your area by visiting www.jandy.com or by calling our technical 
support department at (707) 776-8200 extension 260. All returned parts must have a Returned Material 
Authorization number to be evaluated under the terms of this warranty.

6000 Condor Drive • Moorpark, CA USA 93021  •  707.776.8200  •  Fax 707.763.7785
Jandy Pool Products, Inc.

Litho in U.S.A. © Jandy Pool Products, Inc. 0708
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